wie Erweiterung der Kompatibilität mit Firefox zu zwingen 3.6+

Wenn Sie bereits mit Firefox 3.6 aktualisiert haben, haben Sie vielleicht bemerkt, dass viele Ihrer Erweiterungen nicht mehr funktionieren, und der alte checkCompatibility Trick funktioniert nicht mehr. Oder doch?

Dank meiner guten Kumpel Daniel für den Hinweis die Änderung in Firefox 3.6. Sein persönliches Blog ist so nerdy es wird Ihren Kopf explodieren.

Force-Erweiterung Kompatibilität mit Firefox 3.6+

Das ist der Fehler, den Sie erhalten, wenn Sie versuchen, eine Erweiterung zu installieren, die nicht kompatibel ist. Achten Sie besonders auf die Firefox-Version String, wie wir später benötigen.

Geben Sie about: config in die Adressleiste, und dann, nachdem sie durch die Warnung klicken, werden Sie wollen der rechten Maustaste in der Liste und wählen Sie Neu -> Boolean aus dem Menü.

Jetzt werden wir aufgefordert, den Vorzug Namen einzugeben. Hier können Sie die Aufmerksamkeit auf die genaue Version zahlen müssen Sie verwenden, da die Vorliebe für die genaue Version von Firefox Sie verwenden eingestellt werden muss.

Wir verwenden Firefox 3.6b3, wie oben in der Fehlermeldung, so dass die Präferenz wäre, die folgende … beachten Sie die Hauptstadt C gibt, sehr wichtig.

Update: Für die aktuelle Firefox 3.6 Release Candidate müssen Sie die folgende

extensions.checkCompatibility.3.6

Im Grunde genommen ist das Format extensions.checkCompatibility.VERSION.b für Beta-Versionen oder extensions.checkCompatibility.VERSION.a für Alpha veröffentlicht. Also, wenn Sie testeten aus Firefox 3.8 Alpha, würden Sie extensions.checkCompatibility.3.8a als Präferenz Namen verwenden.

Ja, das war nicht die einfachste Sache. Im nächsten Dialog wählen Sie einfach “falsch” und den Dialog zu schließen.

Sie sollten nun den Wert in der Liste sehen, ob sie es filtern.

Und Ihre Erweiterungen sollten jetzt installieren. Wenn sie dies nicht tun, dann setzen Sie wahrscheinlich die falsche Version in die Präferenz Namen.

Auf jeden Fall ein sehr nützlicher Tipp, und eine, die ich vermute, ich werde die ganze Zeit werden.

Es gibt einen einfacheren Weg – die Nightly Tester Tools Add-on. Setzt eine Schaltfläche in der Add-ons Sidebar Kompatibilität außer Kraft setzen.

Die Nightly Tester Tools fügt eine ganze Reihe von anderen Sachen, die die meisten von uns nicht wollen. Ich würde lieber tun, nur die schnelle zwicken statt, und halten Sie meine Erweiterungsliste kleiner.

Vielen Dank für die zwicken! Ich habe mich gefragt, was los war.

Große zwicken hatte ich keine Ahnung, dass Sie dies tun könnte

Süß! Ich kann jetzt Firefox 3.6 wieder verwenden. Ich installierte es und hatte Probleme, so dass ich aufgehört es zu benutzen, aber mit dieser kann ich es jetzt verwenden.

Eigentlich mag ich das neue Add-on Compatibility Reporter von Mozilla. Es legt die Kompatibilitätsflags in Config für Sie. Dann, nachdem Sie die Erweiterungen getestet haben, können Sie Berichte an die Add-on-Entwickler schicken sie ihre Erweiterungen kompatibel sind wissen zu lassen.

https://addons.mozilla.org/en-US/firefox/addon/15003

Ja, das ist die erste Einstellung, die ich verwenden, wenn Sie ein neues Profil einrichten.

Nun, das kann zu Problemen führen und kann abstürzen, firefox. Ein anderer Weg, um ein bestimmtes Add-on Arbeits

1> Laden Sie die XPI-Datei direkt (Rechtsklick auf die Schaltfläche Installieren, Ziel speichern unter)

2> Entpacken Sie die XPI-Datei Winrar oder ein solches Tool verwenden.

3> Bearbeiten Sie die Datei install.rdf – Änderung Versionsnummer 3.6 oder etwas anderes. Datei speichern.

4> Zip die Datei erneut. Ändern Sie die Erweiterung (.zip to.xpi) – Installieren Sie das Add-on durch Ziehen.

Zum Glück wird diese Methode den Browser nicht abstürzen – und Sie können setings für individuelle Add-ons ändern

Prost!

Herzlichen Dank für diesen Tipp. Ich benutze Roboform viele Passwörter zu speichern, und es ist toll, es wieder zu haben, anstatt IE öffnen, wann immer ich eine Website besuchen, wo ich ein Passwort und einen Benutzernamen benötigen.

Sehr hilfreich.

MR Tech Toolkit Add-on immer von der Frage kümmern.

“MR Tech Toolkit Add-on immer kümmern sich um die Frage” große Antwort, das ist, warum ich zitierte Sie Broni, genau das, was ich sagen wollte, jedes Mal funktioniert.

Vielen Dank. Es ist nur die Informationen, die ich FF Upgrade benötigt 3.6

… du hast mir den Tag gerettet !!

Hallo Jungs, ich folgte den Schritten für diese, aber wenn ich Motoren wechseln, eine Website mit dem IE Tab öffnen Add-on ein jusf stoppen und sagt LODAING auf der Registerkarte Name und zeigt nie die Seite, irgendwelche Hinweise ???? ;Danke

schöne Code ….!

Was muss ich für die Codeart WENN MEIN VERSION 3.6.13 IST?

Muttermilch enthält Grad von Melatonin auf der Grundlage der Tageszeit variiert; die Melatoningehalt hilft das Baby seinen Schlafzyklus zu regulieren und reduziert Vorfälle von Koliken.